[BACK]Return to Makefile.template CVS log [TXT][DIR] Up to [local] / ports

Annotation of ports/Makefile.template, Revision 1.1

1.1     ! marc        1: # $OpenBSD:$
        !             2: #
        !             3: # Replace ??? with appropriate values
        !             4: # Remove extraneous comments before commit.
        !             5:
        !             6: #
        !             7: # What port/package will be created
        !             8: #
        !             9: DISTNAME=              ???
        !            10: #DIST_SUBDIR=          ???
        !            11: #PKGNAME=              ???
        !            12: CATEGORIES=            ???
        !            13:
        !            14: # Reasons why the port/package shouldn't be built
        !            15: #
        !            16: #NEED_VERSION=         ?.??
        !            17: #COMES_WITH=           ???
        !            18: #ONLY_FOR_ARCHS=       ???
        !            19: #BROKEN=               "reason"
        !            20: #NO_CDROM=             "reason"
        !            21: #RESTRICTED=           "reason"
        !            22: #MIRROR_DISTFILE=      no
        !            23:
        !            24: # where to send bitches about this port
        !            25: #
        !            26: MAINTAINER=            ports@openbsd.org
        !            27:
        !            28: # where the source files and patches can be fetched
        !            29: #
        !            30: MASTER_SITES=          ???
        !            31: #MASTER_SITE_SUBDIR=   ???
        !            32: #DISTFILES=            ???
        !            33: #PATCH_SITES=          ???
        !            34: #PATCHFILES=           ???
        !            35: #PATCH_DIST_STRIP=     -p0
        !            36: #EXTRACT_SUFX=         .tar.Z
        !            37: #EXTRACT_CMD=          ???
        !            38: #EXTRACT_BEFORE_ARGS=  ???
        !            39: #EXTRACT_AFTER_ARGS=   ???
        !            40:
        !            41: # Dependencies
        !            42: #
        !            43: #FETCH_DEPENDS=                ???
        !            44: #BUILD_DEPENDS=                ???
        !            45: #RUN_DEPENDS=          ???
        !            46: #LIB_DEPENDS=          ???
        !            47:
        !            48: # Is the build automagic or is it interactive
        !            49: #
        !            50: #IS_INTERACTIVE=       yes
        !            51:
        !            52: # build/configuration variables
        !            53: #
        !            54: #SEPARATE_BUILD=       yes (requires bsd.port.mk 1.71 or later)
        !            55: #USE_EGCC=             yes
        !            56: #USE_EGXX=             yes
        !            57: #USE_GMAKE=            yes
        !            58: #USE_IMAKE=            yes
        !            59: #USE_X11=              yes (assumed if USE_IMAKE is yes)
        !            60: #USE_AUTOCONF=         yes
        !            61: #GNU_CONFIGURE=                yes (assumed if USE_AUTOCONF is yes)
        !            62: #HAS_CONFIGURE=                yes (assumed if GNU_CONFIGURE is yes)
        !            63: #CONFIGURE_SCRIPT=     ??? (if other than configure)
        !            64: #.if !defined(NO_SHARED_LIBS)
        !            65: #CONFIGURE_ARGS+=      --enable-shared
        !            66: #.endif
        !            67: #CONFIGURE_ARGS+=      --enable-static
        !            68: #CONFIGURE_ENV=                ???
        !            69:
        !            70: # Things that we don't want to do for this port/package
        !            71: #
        !            72: #NO_DEPENDS=           yes
        !            73: #NO_WRKDIR=            yes
        !            74: #NO_WRKSUBDIR=         yes
        !            75: #NO_CHECKSUM=          yes
        !            76: #NO_EXTRACT=           yes
        !            77: #NO_PATCH=             yes
        !            78: #NO_CONFIGURE=         yes
        !            79: #NO_BUILD=             yes
        !            80: #NO_INSTALL=           yes
        !            81: #NO_MTREE=             yes
        !            82: #NO_PACKAGE=           yes
        !            83: #NO_PKG_REGISTER=      yes
        !            84:
        !            85: # This section is only needed if man pages are distributed in compressed
        !            86: # form.  Define MANCOMPRESSED and the man pages by section.  The pages
        !            87: # will be uncompressed after being installed.
        !            88: #
        !            89: #MANCOMPRESSED=                yes
        !            90: #MAN1=                 ???
        !            91: #MAN3=                 ???
        !            92: #MAN4=                 ???
        !            93: #MAN5=                 ???
        !            94: #MAN8=                 ???
        !            95:
        !            96: # Overrides for default values
        !            97: #
        !            98: #MAKEFILE=             ???
        !            99: #MAKE_FLAGS=           ???
        !           100: #MAKE_ENV=             ???
        !           101: #SCRIPTS_ENV=          ???
        !           102: #LDFLAGS=              ???
        !           103: #WRKDIR=               ??? if other than work
        !           104: #WRKSRC=               ??? if other than ${WRKDIR}/$DISTNAME
        !           105:
        !           106: #ALL_TARGET=           ???
        !           107: #INSTALL_TARGET=       ???
        !           108:
        !           109: # This target may be necessary if a shared library may have been created
        !           110: #
        !           111: #post-install:
        !           112: #      ${LDCONFIG} -m ${PREFIX}/lib
        !           113:
        !           114: .include <bsd.port.mk>