[BACK]Return to Makefile.template CVS log [TXT][DIR] Up to [local] / ports

Annotation of ports/Makefile.template, Revision 1.3

1.3     ! espie       1: # $OpenBSD: Makefile.template,v 1.2 1999/03/02 04:41:00 marc Exp $
1.1       marc        2: #
                      3: # Replace ??? with appropriate values
                      4: # Remove extraneous comments before commit.
                      5:
                      6: #
                      7: # What port/package will be created
                      8: #
                      9: DISTNAME=              ???
                     10: #DIST_SUBDIR=          ???
                     11: #PKGNAME=              ???
                     12: CATEGORIES=            ???
                     13:
                     14: # Reasons why the port/package shouldn't be built
                     15: #
                     16: #NEED_VERSION=         ?.??
                     17: #COMES_WITH=           ???
                     18: #ONLY_FOR_ARCHS=       ???
                     19: #BROKEN=               "reason"
                     20: #NO_CDROM=             "reason"
                     21: #RESTRICTED=           "reason"
                     22: #MIRROR_DISTFILE=      no
                     23:
                     24: # where to send bitches about this port
                     25: #
                     26: MAINTAINER=            ports@openbsd.org
                     27:
                     28: # where the source files and patches can be fetched
                     29: #
                     30: MASTER_SITES=          ???
                     31: #MASTER_SITE_SUBDIR=   ???
                     32: #DISTFILES=            ???
                     33: #PATCH_SITES=          ???
                     34: #PATCHFILES=           ???
                     35: #PATCH_DIST_STRIP=     -p0
                     36: #EXTRACT_SUFX=         .tar.Z
                     37: #EXTRACT_CMD=          ???
                     38: #EXTRACT_BEFORE_ARGS=  ???
                     39: #EXTRACT_AFTER_ARGS=   ???
                     40:
                     41: # Dependencies
                     42: #
                     43: #FETCH_DEPENDS=                ???
                     44: #BUILD_DEPENDS=                ???
                     45: #RUN_DEPENDS=          ???
                     46: #LIB_DEPENDS=          ???
                     47:
                     48: # Is the build automagic or is it interactive
                     49: #
                     50: #IS_INTERACTIVE=       yes
                     51:
                     52: # build/configuration variables
                     53: #
1.3     ! espie      54: # requires bsd.port.mk 1.71 or later
        !            55: #SEPARATE_BUILD=       concurrent  (build simultaneously on all arches)
        !            56: #SEPARATE_BUILD=       simple  (configure/build still recreates files in source)
1.1       marc       57: #USE_EGCC=             yes
                     58: #USE_EGXX=             yes
                     59: #USE_GMAKE=            yes
                     60: #USE_IMAKE=            yes
                     61: #USE_X11=              yes (assumed if USE_IMAKE is yes)
                     62: #USE_AUTOCONF=         yes
                     63: #GNU_CONFIGURE=                yes (assumed if USE_AUTOCONF is yes)
                     64: #HAS_CONFIGURE=                yes (assumed if GNU_CONFIGURE is yes)
                     65: #CONFIGURE_SCRIPT=     ??? (if other than configure)
1.2       marc       66: #CONFIGURE_ARGS+=      ${CONFIGURE_SHARED}
1.1       marc       67: #CONFIGURE_ENV=                ???
                     68:
                     69: # Things that we don't want to do for this port/package
                     70: #
                     71: #NO_DEPENDS=           yes
                     72: #NO_WRKDIR=            yes
                     73: #NO_WRKSUBDIR=         yes
                     74: #NO_CHECKSUM=          yes
                     75: #NO_EXTRACT=           yes
                     76: #NO_PATCH=             yes
                     77: #NO_CONFIGURE=         yes
                     78: #NO_BUILD=             yes
                     79: #NO_INSTALL=           yes
                     80: #NO_MTREE=             yes
                     81: #NO_PACKAGE=           yes
                     82: #NO_PKG_REGISTER=      yes
                     83:
                     84: # This section is only needed if man pages are distributed in compressed
                     85: # form.  Define MANCOMPRESSED and the man pages by section.  The pages
                     86: # will be uncompressed after being installed.
                     87: #
                     88: #MANCOMPRESSED=                yes
                     89: #MAN1=                 ???
                     90: #MAN3=                 ???
                     91: #MAN4=                 ???
                     92: #MAN5=                 ???
                     93: #MAN8=                 ???
                     94:
                     95: # Overrides for default values
                     96: #
                     97: #MAKEFILE=             ???
                     98: #MAKE_FLAGS=           ???
                     99: #MAKE_ENV=             ???
                    100: #SCRIPTS_ENV=          ???
                    101: #LDFLAGS=              ???
                    102: #WRKDIR=               ??? if other than work
                    103: #WRKSRC=               ??? if other than ${WRKDIR}/$DISTNAME
                    104:
                    105: #ALL_TARGET=           ???
                    106: #INSTALL_TARGET=       ???
                    107:
                    108: # This target may be necessary if a shared library may have been created
                    109: #
                    110: #post-install:
                    111: #      ${LDCONFIG} -m ${PREFIX}/lib
                    112:
                    113: .include <bsd.port.mk>