[BACK]Return to Makefile.template CVS log [TXT][DIR] Up to [local] / ports

Annotation of ports/Makefile.template, Revision 1.5

1.5     ! rohee       1: # $OpenBSD: Makefile.template,v 1.4 1999/04/08 18:54:55 marc Exp $
1.4       marc        2: # $FreeBSD/NetBSD: credit FreeBSD/NetBSD if thats where the port came from $
                      3: # Original from: credit the original author here
1.1       marc        4: #
                      5: # Replace ??? with appropriate values
                      6: # Remove extraneous comments before commit.
                      7:
                      8: #
                      9: # What port/package will be created
                     10: #
                     11: DISTNAME=              ???
                     12: #DIST_SUBDIR=          ???
                     13: #PKGNAME=              ???
                     14: CATEGORIES=            ???
                     15:
                     16: # Reasons why the port/package shouldn't be built
                     17: #
                     18: #NEED_VERSION=         ?.??
                     19: #COMES_WITH=           ???
                     20: #ONLY_FOR_ARCHS=       ???
                     21: #BROKEN=               "reason"
                     22: #NO_CDROM=             "reason"
                     23: #RESTRICTED=           "reason"
                     24: #MIRROR_DISTFILE=      no
                     25:
                     26: # where to send bitches about this port
                     27: #
                     28: MAINTAINER=            ports@openbsd.org
                     29:
                     30: # where the source files and patches can be fetched
                     31: #
                     32: MASTER_SITES=          ???
                     33: #MASTER_SITE_SUBDIR=   ???
                     34: #DISTFILES=            ???
                     35: #PATCH_SITES=          ???
                     36: #PATCHFILES=           ???
                     37: #PATCH_DIST_STRIP=     -p0
                     38: #EXTRACT_SUFX=         .tar.Z
                     39: #EXTRACT_CMD=          ???
                     40: #EXTRACT_BEFORE_ARGS=  ???
                     41: #EXTRACT_AFTER_ARGS=   ???
                     42:
                     43: # Dependencies
                     44: #
                     45: #FETCH_DEPENDS=                ???
                     46: #BUILD_DEPENDS=                ???
                     47: #RUN_DEPENDS=          ???
                     48: #LIB_DEPENDS=          ???
                     49:
                     50: # Is the build automagic or is it interactive
                     51: #
                     52: #IS_INTERACTIVE=       yes
                     53:
                     54: # build/configuration variables
                     55: #
1.3       espie      56: # requires bsd.port.mk 1.71 or later
                     57: #SEPARATE_BUILD=       concurrent  (build simultaneously on all arches)
                     58: #SEPARATE_BUILD=       simple  (configure/build still recreates files in source)
1.1       marc       59: #USE_EGCC=             yes
                     60: #USE_EGXX=             yes
                     61: #USE_GMAKE=            yes
                     62: #USE_IMAKE=            yes
                     63: #USE_X11=              yes (assumed if USE_IMAKE is yes)
                     64: #USE_AUTOCONF=         yes
1.5     ! rohee      65: #USE_LIBTOOL=          yes # require 1.89 or later
1.1       marc       66: #GNU_CONFIGURE=                yes (assumed if USE_AUTOCONF is yes)
                     67: #HAS_CONFIGURE=                yes (assumed if GNU_CONFIGURE is yes)
                     68: #CONFIGURE_SCRIPT=     ??? (if other than configure)
1.2       marc       69: #CONFIGURE_ARGS+=      ${CONFIGURE_SHARED}
1.1       marc       70: #CONFIGURE_ENV=                ???
1.5     ! rohee      71: #LIBTOOL_FLAGS=                ???
1.1       marc       72:
                     73: # Things that we don't want to do for this port/package
                     74: #
                     75: #NO_DEPENDS=           yes
                     76: #NO_WRKDIR=            yes
                     77: #NO_WRKSUBDIR=         yes
                     78: #NO_CHECKSUM=          yes
                     79: #NO_EXTRACT=           yes
                     80: #NO_PATCH=             yes
                     81: #NO_CONFIGURE=         yes
                     82: #NO_BUILD=             yes
                     83: #NO_INSTALL=           yes
                     84: #NO_MTREE=             yes
                     85: #NO_PACKAGE=           yes
                     86: #NO_PKG_REGISTER=      yes
                     87:
                     88: # This section is only needed if man pages are distributed in compressed
                     89: # form.  Define MANCOMPRESSED and the man pages by section.  The pages
                     90: # will be uncompressed after being installed.
                     91: #
                     92: #MANCOMPRESSED=                yes
                     93: #MAN1=                 ???
                     94: #MAN3=                 ???
                     95: #MAN4=                 ???
                     96: #MAN5=                 ???
                     97: #MAN8=                 ???
                     98:
                     99: # Overrides for default values
                    100: #
                    101: #MAKEFILE=             ???
                    102: #MAKE_FLAGS=           ???
                    103: #MAKE_ENV=             ???
                    104: #SCRIPTS_ENV=          ???
                    105: #LDFLAGS=              ???
                    106: #WRKDIR=               ??? if other than work
                    107: #WRKSRC=               ??? if other than ${WRKDIR}/$DISTNAME
                    108:
                    109: #ALL_TARGET=           ???
                    110: #INSTALL_TARGET=       ???
                    111:
                    112: # This target may be necessary if a shared library may have been created
                    113: #
                    114: #post-install:
                    115: #      ${LDCONFIG} -m ${PREFIX}/lib
                    116:
                    117: .include <bsd.port.mk>