[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / audio / ncmpc

File: [local] / ports / audio / ncmpc / Makefile (download)

Revision 1.62, Tue Sep 5 16:13:40 2023 UTC (8 months, 3 weeks ago) by espie
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, OPENBSD_7_4_BASE, OPENBSD_7_4, HEAD
Changes since 1.61: +1 -1 lines

move to new sites format

COMMENT=		curses based frontend for mpd

VER=			0.49
DISTNAME=		ncmpc-${VER}
EPOCH=			0
CATEGORIES=		audio

HOMEPAGE=		https://www.musicpd.org/clients/ncmpc/

# GPLv2
PERMIT_PACKAGE=	Yes

# make sure to regen WANTLIB on ld.lld arches (-Wl,--as-needed)
WANTLIB +=	${COMPILER_LIBCXX} c curses iconv intl m mpdclient>=1
WANTLIB +=	pcre2-8

SITES=			https://www.musicpd.org/download/ncmpc/${VER:R}/

EXTRACT_SUFX=		.tar.xz

# c++17
COMPILER =		base-clang ports-gcc

MODULES=		devel/meson

BUILD_DEPENDS=		devel/boost \
			devel/gettext,-tools \
			textproc/py-sphinx,python3

LIB_DEPENDS=		audio/libmpdclient>=2.20 \
			devel/gettext,-runtime \
			devel/pcre2

CONFIGURE_ARGS=		-Dlirc=disabled \
			-Dhtml_manual=false \
			-Dlocale=enabled \
			-Dmouse=enabled

# disable meson's default of using "-Wl,--as-needed" on ld.bfd arches;
# build failures due to undefined references are often seen.
.include <bsd.port.arch.mk>
.if !${PROPERTIES:Mlld}
CONFIGURE_ARGS +=	-Db_asneeded=false
.endif

CONFIGURE_ENV=		CPP=${CPP} \
			CPPFLAGS="-D_GNU_SOURCE \
				  -D_DEFAULT_SOURCE \
				  -I${LOCALBASE}/include" \
			LDFLAGS="-L${LOCALBASE}/lib -lintl"

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/examples/ncmpc
	mv ${PREFIX}/share/doc/ncmpc/{config.sample,keys.sample,ncmpc.lirc} \
		${PREFIX}/share/examples/ncmpc/

.include <bsd.port.mk>