[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / audio / vorbis-tools

File: [local] / ports / audio / vorbis-tools / Makefile (download)

Revision 1.59, Sun Nov 5 22:20:52 2023 UTC (6 months, 3 weeks ago) by naddy
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, HEAD
Changes since 1.58: +1 -0 lines

audio/vorbis-tools: fix a buffer overflow in oggenc

CVE-2023-43361
The security implications of this are very limited.

COMMENT=	play, encode, and manage Ogg Vorbis files

DISTNAME=	vorbis-tools-1.4.2
REVISION=	0
CATEGORIES=    	audio
HOMEPAGE=	https://xiph.org/vorbis/

MAINTAINER=	Christian Weisgerber <naddy@openbsd.org>

# GPLv2
PERMIT_PACKAGE=	Yes

SITES=		https://downloads.xiph.org/releases/vorbis/

LIB_DEPENDS=	audio/flac \
		audio/libao \
		audio/libvorbis \
		audio/opusfile \
		audio/speex \
		devel/gettext,-runtime \
		net/curl

WANTLIB=	FLAC ao c crypto curl iconv intl m nghttp2 ogg opus opusfile \
		pthread speex ssl vorbis vorbisenc vorbisfile z

CONFIGURE_STYLE=gnu
CONFIGURE_ARGS=	--without-kate
CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
		LDFLAGS="-L${LOCALBASE}/lib"
SEPARATE_BUILD=	Yes

DEBUG_PACKAGES=	${BUILD_PACKAGES}

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/examples/vorbis-tools
	${INSTALL_DATA} ${WRKSRC}/ogg123/ogg123rc-example \
		${PREFIX}/share/examples/vorbis-tools/ogg123rc

.include <bsd.port.mk>