[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / audio / xmp

File: [local] / ports / audio / xmp / Makefile (download)

Revision 1.63, Tue Nov 7 14:19:21 2023 UTC (6 months, 3 weeks ago) by naddy
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, HEAD
Changes since 1.62: +2 -1 lines

http://*sourceforge.net now redirect to https

Update SITES, HOMEPAGE, and comments.

COMMENT=		extended module player

DISTNAME=		xmp-4.2.0
CATEGORIES=		audio
REVISION=		0

HOMEPAGE=		https://xmp.sourceforge.net/

# GPLv2+
PERMIT_PACKAGE=	Yes

SITES=			${SITE_SOURCEFORGE:=xmp/}

WANTLIB += c sndio xmp

USE_GMAKE=		Yes

NO_TEST=		Yes

LIB_DEPENDS=		audio/libxmp

CONFIGURE_STYLE=	gnu
MODGNU_CONFIG_GUESS_DIRS= ${WRKSRC}/build-aux
CONFIGURE_ARGS+=	--disable-alsa \
			--disable-oss \
			--disable-pulseaudio
CONFIGURE_ENV=		CPPFLAGS="-I${LOCALBASE}/include" \
			LDFLAGS="-L${LOCALBASE}/lib"

# disable sun audio detection
CONFIGURE_ENV+=		ac_cv_header_sys_audioio_h=no

MAKE_FLAGS+=		V=1

FAKE_FLAGS=		DESTDIR=${WRKINST} \
			SYSCONFDIR=${PREFIX}/share/examples

.include <bsd.port.mk>