[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / devel / cargo-audit

File: [local] / ports / devel / cargo-audit / Makefile (download)

Revision 1.9, Mon Jan 1 09:02:15 2024 UTC (5 months ago) by semarie
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, HEAD
Changes since 1.8: +1 -1 lines

rust ports cleanup: use MODCARGO_WANTLIB in WANTLIB

fix WANTLIB for simple ports. rust ports are expected to use MODCARGO_WANTLIB
instead of hardcoding values (which will be soon different across archs).

replace "c c++abi pthread" by ${MODCARGO_WANTLIB} in WANTLIB

no changes, as it is the current value of MODCARGO_WANTLIB (even if buggy).

ok tb@

COMMENT =		audit Cargo.lock files for security vulnerabilities

# https://github.com/rustsec/rustsec/issues/429
V =			0.13.1
REVISION =		3
CRATE =			cargo-audit
PKGNAME =		${CRATE}-${V}

DISTFILES =		${PKGNAME}${EXTRACT_SUFX}{${CRATE}/${V}/download}

SITES =			https://crates.io/api/v1/crates/

CATEGORIES =		devel

HOMEPAGE =		https://github.com/RustSec/rustsec/tree/main/cargo-audit

# Apache 2/MIT
PERMIT_PACKAGE =	Yes

WANTLIB += ${MODCARGO_WANTLIB} crypto git2 m ssh2 ssl

LIB_DEPENDS =		devel/libgit2/libgit2 \
			security/libssh2

MODULES =		devel/cargo
# for riscv64 and powerpc64, please keep: cc >= 1.0.73 and libc >= 0.2.113
MODCARGO_CRATES_UPDATE =	cc libc

CONFIGURE_STYLE =	cargo
SEPARATE_BUILD =	Yes

WRKSRC =		${WRKDIR}/${PKGNAME}

post-patch:
	${SUBST_CMD} ${WRKSRC}/modcargo-crates/canonical-path-2.0.2/src/lib.rs

.include "crates.inc"

.include <bsd.port.mk>