[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / devel / gitsh

File: [local] / ports / devel / gitsh / Makefile (download)

Revision 1.19, Thu Sep 21 09:49:54 2023 UTC (8 months, 1 week ago) by espie
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, OPENBSD_7_4_BASE, OPENBSD_7_4, HEAD
Changes since 1.18: +1 -1 lines

-> SITES

VERSION =		0.13
REVISION =		4

COMMENT =		interactive shell for git

DISTNAME =		gitsh-${VERSION}

CATEGORIES =		devel

HOMEPAGE =		https://github.com/thoughtbot/gitsh

MAINTAINER =		Mike Burns <mike+openbsd@mike-burns.com>

# License: BSD
PERMIT_PACKAGE =	Yes

# Ruby 3.2 libs need ports-gcc
COMPILER =		base-clang ports-gcc

WANTLIB +=		ereadline curses ${MODRUBY_WANTLIB}

SITES =			${HOMEPAGE}/releases/download/v${VERSION}/

MODULES =		lang/ruby
RUN_DEPENDS =		devel/git
LIB_DEPENDS =		devel/readline

CONFIGURE_STYLE =	gnu
CONFIGURE_ENV =		READLINE_LIB="ereadline" \
			CPPFLAGS="-I${LOCALBASE}/include/ereadline" \
			LDFLAGS="-L${LOCALBASE}/lib" \
			RUBY="${RUBY}"

.include <bsd.port.mk>