[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / editors / nano

File: [local] / ports / editors / nano / Makefile (download)

Revision 1.134, Thu May 9 14:08:32 2024 UTC (3 weeks, 2 days ago) by naddy
Branch: MAIN
CVS Tags: HEAD
Changes since 1.133: +2 -2 lines

editors/nano: update to 8.0

Improvements:
- To accommodate newcomers, ^F now starts a forward search.
- Option --modernbindings makes ^Q quit, ^X cut, ^C copy, ^V paste,
  ^Z undo, ^Y redo, ^O open a file, and ^G find again, among others.
- M-Home/M-End put the cursor on the first/last row in the viewport.
- With `nano filename:number` the given file will be opened with the
  cursor on the given line number.

COMMENT=	simple editor, inspired by Pico

DISTNAME=	nano-8.0
CATEGORIES=	editors
HOMEPAGE=	https://www.nano-editor.org/

MAINTAINER=	Christian Weisgerber <naddy@openbsd.org>

SITES=		https://www.nano-editor.org/dist/v8/ \
		${SITE_GNU:=nano/}
PORTROACH=	site:https://www.nano-editor.org/dist/latest/
EXTRACT_SUFX=	.tar.xz

# GPLv3+
PERMIT_PACKAGE=	Yes

LIB_DEPENDS=	devel/gettext,-runtime
WANTLIB=	c curses iconv intl

CONFIGURE_STYLE=gnu
CONFIGURE_ARGS=	--disable-libmagic
CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
		LDFLAGS="-L${LOCALBASE}/lib"

DEBUG_PACKAGES=	${BUILD_PACKAGES}

# configure tests for groff -Thtml, but assumes the existence of groff
pre-configure:
	@ln -s /usr/bin/false ${WRKDIR}/bin/groff

post-install:
	sed -i -e 's:/etc:${SYSCONFDIR}:g' -e 's:/usr:${TRUEPREFIX}:g' \
	    ${PREFIX}/man/man1/nano.1 ${PREFIX}/man/man5/nanorc.5
	${INSTALL_DATA_DIR} ${PREFIX}/share/examples/nano
	${INSTALL_DATA} ${WRKBUILD}/doc/sample.nanorc \
	    ${PREFIX}/share/examples/nano

.include <bsd.port.mk>