[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / fonts / luciole

File: [local] / ports / fonts / luciole / Makefile (download)

Revision 1.3, Thu Sep 21 15:28:09 2023 UTC (8 months, 1 week ago) by espie
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, OPENBSD_7_4_BASE, OPENBSD_7_4, HEAD
Changes since 1.2: +1 -1 lines

->SITES

COMMENT =	typeface developed explicitly for visually impaired people

DISTNAME =	luciole-1.0

CATEGORIES =	fonts

HOMEPAGE =	https://www.luciole-vision.com/

# Creative Commons Attribution 4.0 International Public License
PERMIT_PACKAGE =	Yes

SITES =		https://www.typographies.fr/N/luciole/

DISTFILES =	Luciole-Bold-Italic.ttf \
		Luciole-Bold.ttf \
		Luciole-Regular-Italic.ttf \
		Luciole-Regular.ttf
EXTRACT_ONLY =

NO_BUILD =	Yes
NO_TEST =	Yes

PKG_ARCH =	*

INSTALL_DIR =	${PREFIX}/share/fonts/luciole

pre-install:
.for font in ${DISTFILES}
	cp ${FULLDISTDIR}/${font} ${WRKSRC}
.endfor

do-install:
	${INSTALL_DATA_DIR} ${INSTALL_DIR}
	${INSTALL_DATA} ${WRKSRC}/*.ttf ${INSTALL_DIR}

.include <bsd.port.mk>