[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / cataclysm-dda

File: [local] / ports / games / cataclysm-dda / Makefile (download)

Revision 1.29, Mon Jan 22 01:51:25 2024 UTC (4 months, 1 week ago) by kn
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, HEAD
Changes since 1.28: +2 -0 lines

BDEP on abseil to fix sporadic build failure;  OK kirby rsadowski

Found by naddy, cataclysm-dda bundles flatbuffers which uses abseil-cpp.
Neither checked during configure nor linked to;  devel/flatbuffers does
not pull in devel/abseil-cpp, but cataclysm-dda does not support using
the system library, so satisfy the dependency to avoid dpb(1) junking it.

COMMENT=		rogue-like zombie survival game
CATEGORIES=		games

GH_ACCOUNT=		CleverRaven
GH_PROJECT=		Cataclysm-DDA
GH_TAGNAME=		0.G
DISTNAME=		cataclysm-dda-${GH_TAGNAME}
EPOCH=			0
REVISION=		0

HOMEPAGE=		https://cataclysmdda.org
MAINTAINER=		Kirill Bychkov <kirby@openbsd.org>

# Creative Commons 3.0
PERMIT_PACKAGE=	Yes

FLAVORS=		no_x11
FLAVOR?=

WANTLIB=		${COMPILER_LIBCXX} c iconv intl m z

# C++14
COMPILER=		base-clang ports-gcc

MODULES=		devel/cmake textproc/intltool

BUILD_DEPENDS =		devel/abseil-cpp

RUN_DEPENDS=		devel/desktop-file-utils \
			x11/gtk+4,-guic

LIB_DEPENDS=		devel/gettext,-runtime

CONFIGURE_ARGS = 	-DLOCALIZE=ON \
			-DBACKTRACE=OFF \
			-DGIT_VERSION=${GH_TAGNAME} \
			-DCMAKE_DISABLE_FIND_PACKAGE_Git=ON \
			-DCMAKE_CXX_FLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
			-DCMAKE_EXE_LINKER_FLAGS="-L${LOCALBASE}/lib -lintl -liconv"

SUBST_VARS += 		GH_TAGNAME

.if ${FLAVOR:Mno_x11}
WANTLIB+=		curses form
CONFIGURE_ARGS += 	-DCURSES_INCLUDE_PATH=/usr/include
.else
WANTLIB+=		SDL2 SDL2_image SDL2_mixer SDL2_ttf

LIB_DEPENDS+=		devel/sdl2-mixer \
			devel/sdl2-image \
			devel/sdl2-ttf

CONFIGURE_ARGS+=       -DCURSES=OFF -DTILES=ON -DSOUND=ON

MAN_TILES=		-tiles
.endif

NO_TEST=		Yes

post-extract:
	mv ${WRKSRC}/src/third-party/flatbuffers/ \
		${WRKSRC}/src/third-party/flatbuffers_int/

post-patch:
	${SUBST_CMD} ${WRKSRC}/src/version.cmake
	perl -pi -e 's,flatbuffers/,flatbuffers_int/,g' \
		${WRKSRC}/src/third-party/CMakeLists.txt \
		${WRKSRC}/src/third-party/flatbuffers_int/*.h \
		${WRKSRC}/src/third-party/flatbuffers_int/*.cpp \
		${WRKSRC}/src/third-party/flatbuffers_int/pch/*.h \
		${WRKSRC}/src/main.cpp \
		${WRKSRC}/src/flexbuffer_cache.* \
		${WRKSRC}/src/flexbuffer_json-inl.h \
		${WRKSRC}/src/flexbuffer_json.h \
		${WRKSRC}/pch/main-pch.hpp

post-configure:
	touch ${WRKSRC}/VERSION.txt

post-install:
	${INSTALL_MAN} ${WRKSRC}/doc/cataclysm${MAN_TILES}.6 ${PREFIX}/man/man6/

.include <bsd.port.mk>