[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / nudoku

File: [local] / ports / games / nudoku / Makefile (download)

Revision 1.7, Tue May 7 15:46:11 2024 UTC (3 weeks, 5 days ago) by fcambus
Branch: MAIN
CVS Tags: HEAD
Changes since 1.6: +1 -1 lines

Update nudoku to 4.0.1.

COMMENT =	ncurses based sudoku game

GH_ACCOUNT =	jubalh
GH_PROJECT =	nudoku
GH_TAGNAME =	4.0.1

CATEGORIES =	games

HOMEPAGE =	https://jubalh.github.io/nudoku/

# GPLv3+
PERMIT_PACKAGE =	Yes

WANTLIB +=	c curses iconv intl

BUILD_DEPENDS =	devel/gettext,-tools

LIB_DEPENDS =	converters/libiconv \
		devel/gettext,-runtime

CONFIGURE_STYLE = autoreconf
AUTOCONF_VERSION = 2.71
AUTOMAKE_VERSION = 1.16

CONFIGURE_ENV =	ncursesw_CFLAGS="-D_GNU_SOURCE -D_DEFAULT_SOURCE" \
		ncursesw_LIBS="-lcurses"

post-configure:
	@sed -i 's|"gettext.h"|<libintl.h>|' ${WRKSRC}/src/main.c \
		 ${WRKSRC}/src/sudoku.c

.include <bsd.port.mk>