[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / ttfautohint

File: [local] / ports / graphics / ttfautohint / Makefile (download)

Revision 1.19, Tue Sep 26 11:39:10 2023 UTC (8 months, 1 week ago) by espie
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, OPENBSD_7_4_BASE, OPENBSD_7_4, HEAD
Changes since 1.18: +1 -1 lines

MASTER_SITES -> SITES

COMMENT=		automated hinting process based on FreeType's autohinter #'

DISTNAME =		ttfautohint-1.8.4
SHARED_LIBS +=  ttfautohint               0.0 # 1.0
CATEGORIES =		graphics
REVISION =		0

HOMEPAGE =		https://www.freetype.org/ttfautohint/#download

# FreeType License or GPLv2
PERMIT_PACKAGE =	Yes

SITES =			${SITE_SAVANNAH:=/freetype/}

COMPILER =		base-clang ports-gcc

WANTLIB += c freetype glib-2.0 graphite2 harfbuzz iconv intl m pthread
WANTLIB += pcre2-8 z ${COMPILER_LIBCXX}

LIB_DEPENDS =		devel/harfbuzz

USE_GMAKE =		Yes
CONFIGURE_STYLE =	gnu
CONFIGURE_ARGS +=	--without-doc \
			--without-qt

# gnulib problem: autoconf tests run with -std=gnu99, which hides the
# max_align_t definition (like it should), but then some of the code gets
# compiled with -std=gnu++11, which exposes the definition.
#
# https://lists.gnu.org/archive/html/bug-gnulib/2016-04/msg00003.html

CONFIGURE_ENV =		ac_cv_type_max_align_t=yes

.include <bsd.port.mk>