[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / multimedia / libtheorafile

File: [local] / ports / multimedia / libtheorafile / Makefile (download)

Revision 1.7, Wed Sep 27 10:10:21 2023 UTC (8 months ago) by espie
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, OPENBSD_7_4_BASE, OPENBSD_7_4, HEAD
Changes since 1.6: +1 -1 lines

MASTER_SITES -> SITES

COMMENT =	Ogg Theora Video Decoder Library

# stable release binary packages are only available as part of FNA
# Note that not every update of FNA releases necessarily updates libtheorafile
V =	20210403
FNA =	21.11
DISTNAME =	libtheorafile-${V}{FNA-${FNA:S/.//}}
PKGNAME =	libtheorafile-${V}

SHARED_LIBS =	theorafile	1.1	# from FNA 21.11

CATEGORIES =	multimedia
HOMEPAGE =	https://github.com/FNA-XNA/Theorafile
MAINTAINER =	Thomas Frohwein <thfr@openbsd.org>

# zlib
PERMIT_PACKAGE =	Yes

WANTLIB += m

SITES = 	https://github.com/FNA-XNA/FNA/releases/download/${FNA}/
EXTRACT_SUFX = .zip

MAKE_ENV =	LIBtheorafile_VERSION=${LIBtheorafile_VERSION}
MAKE_FLAGS =	TARGET=so.${LIBtheorafile_VERSION}

USE_GMAKE =	Yes

# Comes with target 'test' to build binary 'theorafile-test' that can play an
# Ogg Theora (.ogv) file. Doesn't come with an example video file, however.
NO_TEST =	Yes

WRKDIST =	${WRKDIR}/FNA/lib/Theorafile

do-install:
	${INSTALL_DATA} ${WRKSRC}/theorafile.h ${PREFIX}/include
	${INSTALL_DATA} ${WRKBUILD}/libtheorafile.so.${LIBtheorafile_VERSION} \
		${PREFIX}/lib

.include <bsd.port.mk>