[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / net / dendrite

File: [local] / ports / net / dendrite / Makefile (download)

Revision 1.28, Thu Apr 11 17:10:39 2024 UTC (7 weeks, 2 days ago) by gonzalo
Branch: MAIN
CVS Tags: HEAD
Changes since 1.27: +3 -1 lines

Update for Dendrite to 0.13.7

OK abieber@

COMMENT =	matrix homeserver written in Go

MODGO_MODNAME =	github.com/matrix-org/dendrite
MODGO_VERSION =	v0.13.7

DISTNAME =	dendrite-${MODGO_VERSION}

CATEGORIES =	net

HOMEPAGE =	https://github.com/matrix-org/dendrite

# Apache 2.0
PERMIT_PACKAGE =	Yes

WANTLIB += c pthread

MODULES =		lang/go

NO_TEST =		Yes

SUBST_VARS =		SYSCONFDIR

post-build:
	mv ${MODGO_WORKSPACE}/bin/create-account \
		${MODGO_WORKSPACE}/bin/dendrite-create-account
	mv ${MODGO_WORKSPACE}/bin/generate-config \
		${MODGO_WORKSPACE}/bin/dendrite-generate-config
	mv ${MODGO_WORKSPACE}/bin/generate-keys \
		${MODGO_WORKSPACE}/bin/dendrite-generate-keys

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/dendrite/
	${INSTALL_DATA} ${WRKSRC}/dendrite-sample.yaml \
		${PREFIX}/share/dendrite/dendrite.yaml

.include "modules.inc"

.include <bsd.port.mk>