[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / security / zkt

File: [local] / ports / security / zkt / Makefile (download)

Revision 1.21, Wed Sep 27 16:34:38 2023 UTC (8 months, 1 week ago) by espie
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, OPENBSD_7_4_BASE, OPENBSD_7_4, HEAD
Changes since 1.20: +1 -1 lines

MASTER_SITES -> SITES

COMMENT=	DNSsec Zone Key Tool

DISTNAME=	zkt-1.1.6
CATEGORIES=	security

# also https://github.com/hzuleger/ZKT http://www.zonekeytool.de/
HOMEPAGE=	https://www.hznet.de/dns/zkt/

# BSD
PERMIT_PACKAGE=	Yes

WANTLIB=	c curses

RUN_DEPENDS=	net/isc-bind
BUILD_DEPENDS=	net/isc-bind
SITES=		${HOMEPAGE}

CONFIGURE_STYLE=	gnu
CONFIGURE_ARGS+=	--enable-configpath=/var/named/etc \
			--enable-bind_util_path=${LOCALBASE}/bin

NO_TEST=		Yes

PROGRAMS=		zkt-conf zkt-keyman zkt-ls zkt-signer zkt-soaserial
MAN8=			zkt-conf.8 zkt-keyman.8 zkt-ls.8 zkt-signer.8

do-install:
.for p in ${PROGRAMS}
	${INSTALL_PROGRAM} ${WRKBUILD}/${p} ${PREFIX}/sbin
.endfor
.for p in ${MAN8}
	${INSTALL_MAN} ${WRKBUILD}/man/${p} ${PREFIX}/man/man8
.endfor

.include <bsd.port.mk>