[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / sysutils / gitlab-cli

File: [local] / ports / sysutils / gitlab-cli / Makefile (download)

Revision 1.22, Sat Apr 27 19:54:00 2024 UTC (4 weeks, 6 days ago) by kn
Branch: MAIN
CVS Tags: HEAD
Changes since 1.21: +1 -1 lines

update to gitlab-cli 1.40.0

COMMENT =		GitLab CLI tool

V =			1.40.0
MODGO_MODNAME =		gitlab.com/gitlab-org/cli
MODGO_VERSION =		v${V}

DISTNAME =		cli-${MODGO_VERSION}
PKGNAME =		gitlab-cli-${V}

CATEGORIES =		sysutils
HOMEPAGE =		https://docs.gitlab.com/ee/integration/glab/

MAINTAINER =		Klemens Nanni <kn@openbsd.org>

# MIT
PERMIT_PACKAGE =	Yes

WANTLIB =		c pthread

MODULES =		lang/go
MODGO_LDFLAGS =		-X main.version=${V}

do-test:
	cd ${WRKSRC} && ${MODGO_TEST_CMD} ./...

post-install:
	${WRKDIR}/go/bin/gen-docs --path ${PREFIX}/man/man1 --manpage
	rm ${PREFIX}/bin/gen-docs

.include "modules.inc"
.include <bsd.port.mk>