[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / textproc / luceneplusplus

File: [local] / ports / textproc / luceneplusplus / Makefile (download)

Revision 1.5, Wed Jan 31 10:36:47 2024 UTC (4 months ago) by op
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, HEAD
Changes since 1.4: +8 -9 lines

update textproc/luceneplusplus to 3.0.8

Disable the tests since ports gtest is not playing well with it.

This update allows to remove the C++17 unary binary function thingy
hack needed for the newer libc++.

V =		3.0.8
PKGNAME =	luceneplusplus-${V}
COMMENT =	C++ port of the Java Lucene library, the text search engine

GH_ACCOUNT =	luceneplusplus
GH_PROJECT =	LucenePlusPlus
GH_TAGNAME =	rel_${V}

SHARED_LIBS +=	lucene++		1.0
SHARED_LIBS +=	lucene++-contrib	1.0

CATEGORIES =	textproc

# LGPL3
PERMIT_PACKAGE =	Yes

WANTLIB += ${COMPILER_LIBCXX} m
WANTLIB += boost_atomic-mt boost_chrono-mt boost_date_time-mt
WANTLIB += boost_filesystem-mt boost_iostreams-mt boost_regex-mt
WANTLIB += boost_system-mt boost_thread-mt z

COMPILER =		base-clang ports-gcc

MODULES =		devel/cmake

LIB_DEPENDS =		devel/boost

# devel/gtest is too new for this
CONFIGURE_ARGS +=	-DENABLE_TEST=FALSE

MODCMAKE_LDFLAGS =	-L${LOCALBASE}/lib

do-test:
	cd ${WRKBUILD} && ./src/test/lucene++-tester \
		--test_dir="${WRKSRC}/src/test/testfiles/"

.include <bsd.port.mk>