[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / www / opensearch-dashboards

File: [local] / ports / www / opensearch-dashboards / Makefile (download)

Revision 1.18, Wed Apr 17 13:02:36 2024 UTC (7 weeks, 3 days ago) by pvk
Branch: MAIN
Changes since 1.17: +1 -1 lines

Update opensearch-dashboards 2.11.1 -> 2.13.3
Release notes: https://github.com/opensearch-project/opensearch-build/blob/main/release-notes/opensearch-release-notes-2.12.0.md
https://github.com/opensearch-project/opensearch-build/blob/main/release-notes/opensearch-release-notes-2.13.0.md
ok op@

COMMENT =	visualization tool for data in OpenSearch

V =		2.13.0
DISTNAME =	opensearch-dashboards-$V-linux-x64
PKGNAME =	opensearch-dashboards-$V

CATEGORIES =	www

HOMEPAGE =	https://www.opensearch.org/

MAINTAINER =	Omar Polo <op@openbsd.org>,\
		Pavel Korovin <pvk@openbsd.org>

SITES =		https://artifacts.opensearch.org/releases/bundle/opensearch-dashboards/$V/

FIX_EXTRACT_PERMISSIONS = Yes

# Apache2
PERMIT_PACKAGE = Yes

RUN_DEPENDS =	lang/node

NO_BUILD =	Yes
NO_TEST =	Yes
PKG_ARCH =	*

WRKDIST =	${WRKDIR}/${PKGNAME}

do-install:
	${SUBST_CMD} ${WRKSRC}/bin/*
	${INSTALL_DATA_DIR} ${PREFIX}/opensearch-dashboards
	${INSTALL_DATA_DIR} ${PREFIX}/share/{doc,examples}/opensearch-dashboards
	${INSTALL_DATA} ${WRKDIST}/*.txt ${PREFIX}/share/doc/opensearch-dashboards
	${INSTALL_DATA} ${WRKDIST}/config/opensearch_dashboards.yml \
		${PREFIX}/share/examples/opensearch-dashboards
	rm -r ${WRKDIST}/src/setup_node_env/*${PATCHORIG} \
		${WRKDIST}/data ${WRKDIST}/{bin/*{${PATCHORIG},.beforesubst},config,node}
	find ${WRKDIST} \( -name '.*' -a ! -name \.cache \) -exec rm -rf {} +
	find ${WRKDIST} -name \*~ -delete
	cd ${WRKDIST} && cp -R * ${PREFIX}/opensearch-dashboards/
	${INSTALL_DATA_DIR} ${PREFIX}/opensearch-dashboards/config
	cd ${PREFIX}/opensearch-dashboards && \
		ln -s ${LOCALSTATEDIR}/opensearch-dashboards/data data
	cd ${PREFIX}/opensearch-dashboards/config && \
		ln -s ${SYSCONFDIR}/opensearch-dashboards/opensearch_dashboards.yml

.include <bsd.port.mk>