[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / x11 / i3status

File: [local] / ports / x11 / i3status / Makefile (download)

Revision 1.66, Wed Sep 27 20:37:14 2023 UTC (8 months ago) by espie
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, OPENBSD_7_4_BASE, OPENBSD_7_4, HEAD
Changes since 1.65: +1 -1 lines

MASTER_SITES -> SITES
now I only need to finish modules!

ONLY_FOR_ARCHS=		${APM_ARCHS}

COMMENT=		generate a statusbar for use with i3/xmobar/dzen2

DISTNAME=		i3status-2.14
CATEGORIES=		x11 sysutils

HOMEPAGE=		https://i3wm.org/i3status/

MAINTAINER=		Robert Nagy <robert@openbsd.org>

# BSD
PERMIT_PACKAGE =	Yes

SITES=			${HOMEPAGE}
EXTRACT_SUFX=		.tar.xz

# C11
COMPILER=		base-clang ports-gcc
COMPILER_LANGS=		c

WANTLIB += c confuse yajl sndio

MODULES=		devel/meson

BUILD_DEPENDS=		textproc/asciidoc>=8.6.8 \
			textproc/xmlto

LIB_DEPENDS=		devel/libconfuse \
			devel/libyajl

CONFIGURE_ARGS+=	-Dsndio=true \
			-Dpulseaudio=false

#FAKE_FLAGS +=		sysconfdir=${PREFIX}/share/examples/i3status/

post-install:
	@${INSTALL_DATA_DIR} ${PREFIX}/share/examples/i3status
	@mv ${WRKINST}/etc/i3status.conf ${PREFIX}/share/examples/i3status

.include <bsd.port.mk>