[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / x11 / picom

File: [local] / ports / x11 / picom / Makefile (download)

Revision 1.12, Tue Feb 27 22:49:57 2024 UTC (3 months ago) by op
Branch: MAIN
CVS Tags: OPENBSD_7_5_BASE, OPENBSD_7_5, HEAD
Changes since 1.11: +5 -8 lines

update x11/picom to 11.2

new features and bugfixes; the changelogs are:

 - https://github.com/yshui/picom/releases/tag/v11-rc1
 - https://github.com/yshui/picom/releases/tag/v11
 - https://github.com/yshui/picom/releases/tag/v11.1
 - https://github.com/yshui/picom/releases/tag/v11.2

Diff from Jose Maldonado (josemald89 at gmail dot com) who also fixed a
compatibility issue upstream, thanks!

COMMENT =	lightweight compositor for X11

DIST_TUPLE =   github yshui picom v11.2 .

CATEGORIES =	x11

# MPL 2.0
PERMIT_PACKAGE =	Yes

WANTLIB += EGL epoxy GL X11 X11-xcb c config dbus-1 ev m pcre2-8 pixman-1
WANTLIB += pthread xcb-composite xcb-damage xcb-glx xcb-image xcb-present
WANTLIB += xcb-randr xcb-render-util xcb-render xcb-shape xcb-sync
WANTLIB += xcb-xfixes xcb-util xcb

MODULES =		devel/meson

# C11
COMPILER =		base-clang ports-gcc
COMPILER_LANGS =	c

BUILD_DEPENDS =		devel/uthash \
			textproc/asciidoc

RUN_DEPENDS =		x11/gtk+4,-guic \
			devel/desktop-file-utils

LIB_DEPENDS =		devel/libconfig \
			devel/libev \
			devel/pcre2 \
			x11/dbus

CONFIGURE_ARGS	+=	-Dwith_docs=true \
			-Dunittest=true \
			-Dcompton=false

CONFIGURE_ENV	+=	CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
			LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/hicolor/{48x48,scalable}/apps
	${INSTALL_DATA} ${WRKSRC}/media/icons/48x48/compton.png \
		${PREFIX}/share/icons/hicolor/48x48/apps/picom.png
	${INSTALL_DATA} ${WRKSRC}/media/compton.svg \
		${PREFIX}/share/icons/hicolor/scalable/apps/picom.svg
	${INSTALL_DATA_DIR} ${PREFIX}/share/examples/picom
	${INSTALL_DATA} ${WRKSRC}/picom.sample.conf \
		${PREFIX}/share/examples/picom

.include <bsd.port.mk>